50b51c Get rid of 12_or_42.sls

Authored and Committed by Christian Boltz 3 years ago
    Get rid of 12_or_42.sls
    
    pillar/osmajorrelease/12_or_42.sls lists some packages that should get
    installed on SLE12, Leap 42.x and in the meantime also Leap 15.x.
    
    Instead of having a special case in top.sls and needing to include
    12_or_42.sls in 15.sls, move everything to top.sls and wrap it with a
    osmajorrelease version conditional.
    
        
file modified
+9 -0
file modified
+0 -1
file modified
+0 -3