5c3054 update relsync config to mostly match upstream

Authored and Committed by Christian Boltz 11 months ago
    update relsync config to mostly match upstream
    
    The updated file is based on
    https://github.com/openSUSE/doc-o-o/blob/main/rn-config/etc/releasenotes
    but still includes 42.3, 15.0 and 15.1.
    
    For >= 15.2 and Tumbleweed, package names get changed to include the
    version in package name ("-L15x" and "-TW").