#19 vagrant 3.X
Opened a year ago by lkocman. Modified a year ago

We would like to refresh vagrant in Leap, however this will require some updates of rubygems on SLE side. Let's consider also 3.x version as there is an effort to rewrite it in GO. a lot of rubygem updates are needed. Latest GO will most likely be needed as well.


Metadata Update from @lkocman:
- Custom field SUSE Jira adjusted to https://jira.suse.com/browse/OPENSUSE-43
- Custom field openSUSE Bugzilla adjusted to https://bugzilla.opensuse.org/show_bug.cgi?id=1188091

a year ago

Metadata Update from @lkocman:
- Issue assigned to lkocman

a year ago

Tagging SLE as it will require updates to various sle components. Vagrant itself is not / will not be part of SLE.

Package was dropped from 15.3 for lack of maintainership, see linked bugzilla. However we seem to found capacity for this release.

Metadata Update from @lkocman:
- Issue tagged with: SLE

a year ago

Metadata Update from @Pharaoh_Atem:
- Issue tagged with: SLE-Accept-Pending

a year ago

Metadata Update from @Pharaoh_Atem:
- Issue set to the milestone: 15.4

a year ago

Asked @dancermak for some research on dependencies.

From Dan:

Assuming that vagrant 3.0 will not be ready for 15.4, then we'll have to go with the ruby based vagrant 2.x, which with vagrant 2.2.18 has the following dependencies:

Ruby 3.0
rubygem-bundler

and the following ruby gems:

"bcrypt_pbkdf", "~> 1.1"
"childprocess", "~> 4.1.0"
"ed25519", "~> 1.2.4"
"erubi"
"i18n", "~> 1.8"
"listen", "~> 3.6"
"hashicorp-checkpoint", "~> 0.1.5"
"log4r", "~> 1.1.9", "< 1.1.11"
"mime-types", "~> 3.3"
"net-ssh", ">= 6.1.0", "< 6.2"
"net-sftp", "~> 3.0"
"net-scp", "~> 3.0.0"
"rb-kqueue", "~> 0.2.0"
"rexml", "~> 3.2"
"rubyzip", "~> 2.0"
"winrm", ">= 2.3.4", "< 3.0"
"winrm-fs", ">= 1.3.4", "< 2.0"
"winrm-elevated", ">= 1.2.1", "< 2.0"
"vagrant_cloud", "~> 3.0.5"

additionally the following test dependencies are required to run the tests:

openssh
curl
bsdtar
rubygem-vagrant-spec

and the following development gems:

"rake", "~> 13.0"
"rspec", "~> 3.10.0"
"rspec-its", "~> 1.3.0"
"fake_ftp", "~> 0.1.1"
"webrick", "~> 1.7.0"

All of these of course drag in a whole ton of additional dependencies and to be really useful, it would require vagrant-libvirt to be included, which will probably need a rather recent libvirt as well.

I would honestly prefer to start as late as possible with this, so that we can grab the latest vagrant version that is out there.

From Dan:

I have created a test project on OBS to build vagrant 2.2.18 for Leap 15.4 Virtualization:vagrant:Leap:15.4 and that resulted in the following packages requiring updates:

rubygem-bcrypt_pbkdf
rubygem-childprocess
rubygem-erubi
rubygem-i18n
rubygem-listen
rubygem-mime-types
rubygem-net-scp
rubygem-net-sftp
rubygem-net-ssh
rubygem-rake
rubygem-rb-fsevent
rubygem-rexml
rubygem-rspec
rubygem-rspec-core
rubygem-rspec-expectations
rubygem-rspec-mocks
rubygem-rspec-support
rubygem-rubyntlm
rubygem-vagrant_cloud
rubygem-vagrant-spec
rubygem-webrick
rubygem-winrm
rubygem-winrm-elevated
rubygem-winrm-fs

plus vagrant and vagrant-libvirt being required as new packages.

The new ruby could be a problem. We'll have to figure out. Perhaps there is a way to stay with an older version, however @dancermak does not recommend to take this path.

Metadata Update from @lkocman:
- Issue untagged with: SLE-Accept-Pending
- Issue tagged with: SLE-Accepted

a year ago

Vagrant recently released 2.2.19 and this requires at least Ruby 2.6. Is there a way how we can get that one?

Login to comment on this ticket.

Metadata