#28 Ship PostGIS in official repos
Opened 2 years ago by predivan. Modified a year ago

PostGIS is one of the more famous/widely used PostgreSQL extensions,
and, AFAIK, the use of spatial databases is growing every year.

I think we agree that Leap would make a great platform for that, so,
IMHO, it would make sense to have PostGIS available in official repos.

I am aware of Application:Geo devel project, and the maintainers of it are doing a great job, but I'd prefer something more...official, if that makes sense?

So I am curious as to are there any technical reasons this might not be feasible, like PostGIS build requirements being behind on Leap, or is upstream moving too fast/breaking things, so the maintenance would be PITA :)


@predivan are you willing to be the maintainer? Otherwise we can ask https://build.opensuse.org/package/users/Application:Geo/postgis whether they'd like to maintain the package in Leap.

Please let us know soon, if you'd like to work on it, you will most likely need also maintainership role for the Application:Geo.

Otherwise we have nothing against adding well maintained packages, however there might be a need in updating some of the underlying libraries/packages coming from SLE.

From what we can see you'd have to fix build for all postrgresql versions and also the failing build on s390x. Otherwise it seems legit.

Metadata Update from @lkocman:
- Issue assigned to lkocman

2 years ago

Metadata Update from @lkocman:
- Assignee reset

2 years ago

Metadata Update from @lkocman:
- Issue assigned to predivan

2 years ago

Metadata Update from @lkocman:
- Issue set to the milestone: 15.4

2 years ago

@predivan are you willing to be the maintainer? Otherwise we can ask https://build.opensuse.org/package/users/Application:Geo/postgis whether they'd like to maintain the package in Leap.

Not really, no, it's a rather complex package, and TBH, I trust the judgement/ability of maintainers in Application:Geo far more then mine, so if they are willing to maintain it in Leap, that would be ideal.

I apologize if this sounds like 'let someone else do the work', it really isn't meant that way, and I will understand completely if maintainers of Application:Geo just don't have time/spare cycles to do it.

Okay so blocking on missing maintainer. We can't really add a package without maintainer.

Metadata Update from @lkocman:
- Issue tagged with: Leap-Maintainer-Missing

a year ago

Tasks for addition of packages to Leap without maintainer will be "auto" closed with Leap 15.4 Beta.

Login to comment on this ticket.

Metadata