#74 Update Ruby to 2.7= to support Rails 7 (preferably 3.1)
Opened 11 months ago by lkocman. Modified 8 months ago

Please upgrade Ruby in the SLE 15 code stream to {{ >= 2.7.0 }} as the upcoming release of Ruby on Rails (version 7) will only support these versions. As we wish to provide developers with a platform to deploy their Rails applications on via the Ruby BCI container, we depend on having an up to date version of the Ruby stack in that container.
Also, Ruby 2.5 (currently in SLE) has reached end of life as well as 2.7. It would thus be preferable to jump directly to the 3.x branch, or at least provide it as an option.

Yast supports 2.5 and 3.1, therefore transition from 3.1 would not be a problem for YaST

Metadata Update from @lkocman:
- Custom field SUSE Jira - SUSE Linux Enterprise adjusted to https://jira.suse.com/browse/SLE-23096

11 months ago

Blocked on resources, the new maintainer is expected to start in FY23, and not before.

Login to comment on this ticket.